3D Survey Pilot - Line mission problem.
« on: October 05, 2021, 07:15:53 PM »
Hello Folks!

Me again reporting another possible bug on the 3DSurvey Pilot App and seeking for your guidance. This time I tested on two different phones with two different drone models and got the same results. I proceed to describe my issues;

* My Flying kit;
-> Drone: DJI P4P V2.0, latest firmware.
-> Phone: Motorola G8 Power Android 11
-> Flying App: 3DSurvey Pilot app latest version from July 14th, 2021.

* Second flying kit;
-> Drone: DJI Mavic pro
-> Phone: Motorola E6S
-> Flying App: 3DSurvey Pilot app latest version from July 14th, 2021.

* The mission that got me the problem;
-> KML lineal mission imported to the Pilot App via KML generated first with QGis and then exported from Google Earth to 3DSurvey Pilot. KML is attached to the post; E377-3-L.zip

* Pipeline I am following to fly;
-> See previous post, 5th message for the pipeline I'm following to successfully execute missions with current android version; https://forum.3dsurvey.si/index.php?topic=38.0

* The problem;
-> Mission upload to drone fails.

* Detailed description of the issue;
-> So this morning I tried to fly a lineal mission in order to survey a road under construction. I got several tips from the video shared by Marko (https://www.youtube.com/watch?v=EcZEMz3nl6M). Sadly he is not using the 3DSurvey Pilot app to fly but the DJI RTK app.

What I did to execute this mission;
At the office I imported the kml into the 3DSurvey Pilot app, configured as it is shown below. Went to the field to install GCP and then proceeded to fly. Did the initial configuration flight to configure camera settings. All good so far. Landed and rebooted all system as I've learnt from my previous posts. Went straight to the 3D Survey Pilot App, opened my stored mission, checked the settings were as prepared at the office, pressed play to do preflight checks. All checks passed but upload mission to drone as shown below.

As I've encountered issues before I did another reboot  of all of the systems (drone + RC + phone) and made sure DJI GO App was closed and not executing in the background after the reboot. Opened 3DSurvey Pilot app, opened my saved mission, same behavior. After this I did several reboots of the systems but had the same result all the time.

I decided to try importing the kml again and defining the settings on site, same behavior same result. Rebooted again, imported kml, defined settings, pressed play, flight check passed but importing mission to drone.

After several tries my coworker decided to go back to the office and fetch his own drone (Mavic 2 Pro) to test on his set up and 3D Survey Pilot App. He has successfully executed missions from polygons before using the app. It took him around 1 hour to reach back in which I tried several times configuring different flying settings to test if it was the settings the problem, in the whole time he was gone I didn't succeed to fly despite trying different options and rebooting several times. Once he arrived I shared the kml line and he tested with his set up. Same result; mission upload failed.

My questions here are;
What am I doing wrong? Do I have a faulty kml line? Do I have wrong flying settings? (I tested several different configurations none worked) Is there a bug with the app? could it be android???

Our final conclusion of the day was that we will try tomorrow again but with a polygon instead of a line, because it has worked fine so far with polygons, this was the first time we tried with a line instead and sadly, we failed. But as you probably know, there is a huge difference between flying a polygon vs flying a line, specially a curvy one as the one of a road.

Any ideas or guidance into this is highly appreciated.


« Last Edit: October 05, 2021, 07:36:26 PM by ocar.campos »
Re: 3D Survey Pilot - Line mission problem.
« Reply #1 on: October 07, 2021, 02:43:53 AM »
Just for the record, today I flew the mission but instead of a line I configured 3 polygons to survey the road, mission was successful and had no issues at all.

Re: 3D Survey Pilot - Line mission problem.
« Reply #2 on: October 07, 2021, 12:51:32 PM »
Dear O'car,

thank you for such a detailed description.

We checked your KML file and the problem is that the 3Dsurvey Pilot app creates 120 way points based on your selected central line but DJI SDK support just 100 waypoints. 

Our suggestion:
- create central line with less waypoints - see image in attachment
- or create shorter mission
- or select less lines... as you already did. But for good accuracy we suggest you minimum 3 lines.

« Last Edit: October 07, 2021, 01:06:15 PM by markom.mesaric »
Re: 3D Survey Pilot - Line mission problem.
« Reply #3 on: October 07, 2021, 10:42:52 PM »
Hello Marko;

Thank you very much for your reply. This is quite interesting and quite an important limit to have in mind when planning a linear mission considering the DJI SDK limitation. Do you think you could add this somewhere as documentation for the 3D Survey Pilot app??

So, just for clarification and future references, if I understood you right problem would be that my line was made with 30 waypoints (just checked at QGis), so then, every planned line at 3D Survey Pilot will have the 30 waypoints. In my case as I planned 4 flying lines, 30*4 == 120 waypoints, which is over the 100 waypoints limit.

Awesome, next week I plan on flying another stretch of that same road, I will make a new line for that mission, this time with less than 25 waypoints (if I can) as I plan always with 4 lines in mind, and will test to see if I succeed!

Thanks again!

« Last Edit: October 07, 2021, 10:46:40 PM by ocar.campos »