3DSurvey Pilot - Drone hovering and not executing
« on: September 15, 2021, 10:49:24 PM »
Hello again folks!

I've been using several more times since my last post the 3DSurvey Pilot App to fly my missions at work. Sadly lately, I would say the last 4-5 missions I've been experiencing a weird behavior with the app and the drone.

The context;

I am using a DJI Phantom 4 Pro V2.0 for flying and the 3DSurvey Pilot App is installed in a Moto G8 Power with Android version 11.

I have imported my polygons from a kml generated first from QGis, then imported to Google Earth, saved again as KML and then imported to 3DSurvey Pilot (check here; https://forum.3dsurvey.si/index.php?topic=35.0).

As for this last step I've done it with several projects and currently I have 8 projects stored on the phone with the corresponding settings and polygon ready to fly.

I have deleted the default launching app for the phone whenever I connect the remote control of the drone to the phone so I can tell the phone manually what application to open every time I connect it to the remote control. It asks me for allowance to run the app and connect it to a DJI Service in android, I always give it permission.

The problem(s);

When I am about to fly I first open the DJI GO 4 app in order to check drone status, do a test flight and configure the necessary settings for the camera to work as I need to. Then I land the drone and close the DJI GO 4 app. I also make sure that it doesn't keep running in the background of the phone.

I then open 3DSurvey Pilot and search for my stored project. I make sure the settings are the ones I configured, make sure drone says connected, and press play. Now problems start;

First problem I found today; I pressed play to send the information to the drone, first try didn't show anything so I backed, tried again, managed to start passing check-ups, all went well but the icon for mission uploading to the drone kept being in red. I tried a couple of more times with no avail. The settings for the flight are as follow;

Path Angle; 91º
Front and side overlap; 80%
Max Speed; 1m/s
Camera Angle; 90º
Flying Height; 25 mts

After trying a couple of times I messed up with flying speed, tried once again with 2 m/s didn't work, tried again with 3 m/s and this time it worked. It was possible to pass all the checks and then it uploaded the mission to drone. I pressed play to start the mission. The drone took off and stayed hovering in the air about 2 meters above ground doing nothing, just hovering, for a lot of seconds. I landed, restarted the mission, corrected flying speed, press play for check-ups, managed to upload mission to drone, pressed play to execute, drone hovering again not doing anything. This happened for a third time. I landed and rebooted everything. Tried again.

I must add that I have experienced this hovering issue around 3-4 times in the past but restarting the drone and the phone fixed the problem and I managed to execute the missions, didn't work this time after rebooting the drone and the phone a couple of times. Then after several tries I managed to execute the mission.

So I went for the second mission of the day.

Same set-up and same specs, different polygon, different location. I rebooted the phone prior to run the missiong. This time I corrected flying speed before the flight. Did the usual DJI GO 4 App configuring and test flight, landed, tried 3DSurvey Pilot, I had several tries because of problems with check-ups, I rebooted the phone, rebooted the drone, launched all again, this time no DJI GO 4 App, straight to 3DSurvey, managed the check-ups, drone hovering in the air. Landed, tried another app (DroneDeploy), up to the air, hovering problem, landed, tried 3DSurvey app, hovering problem, landed, rebooted all again, tried DroneDeploy, worked this time.

I must add that all the flights I do, I do it with my phone in Airplane Mode in order to not have people calling me in the middle of a mission or trying to use the poor internet coverage we have on site.

So, my biggest issue is that the hovering problem is becoming more recurrent in time, it has also happened with DroneDeploy, but as I use more 3DSurvey rather than DroneDeploy I would like to know your point of view into this issue and what could be the reasons behind it. At some point today I even thought it could be the cable connecting the phone with the remote control of the drone.

The problem with the app not being able to upload the mission to the drone was new today, and therefore I decided to seek for guidance here at the forums.

I am also keen to share the polygons I'm using and the specs of the flights I am doing if it adds to find the problem.

Thanks in advance!


Re: 3DSurvey Pilot - Drone hovering and not executing
« Reply #1 on: September 17, 2021, 10:56:05 AM »
Hey Ocar,

Many different things could cause this kind of behavior.
It happend to me that the drone wouldn't start, if I placed it in grass, because a single leaf of grass would disrupt gimbal initialization. Placing a drone on flat surface would help in this case.

If the drone hovers, please try to make some flights in DJI Go 4 and see if it flies there. 
Try also to fly along the waypoints in DJI go 4, and try to also perform compass calibration in DJI go 4.

If nothing else helps, you can try updating the drone firmware as well.

Re: 3DSurvey Pilot - Drone hovering and not executing
« Reply #2 on: September 17, 2021, 10:57:44 AM »
Here is a link with instructions for compass calibration:
Re: 3DSurvey Pilot - Drone hovering and not executing
« Reply #3 on: September 17, 2021, 02:21:15 PM »
Hello Vid;

Thanks for your answer and suggestions, I must add to that the following,

* My pipeline of flight always includes a test flight with DJI Go App before executing the mission, this in order to calibrate the camera settings depending on the light conditions, to be sure that the altitude is right according to possible obstacles in the flying polygon, and in order to capture data to differentiate the photo sets if I need to fly more than one mission while on the field, so I'm always flying before going into the 3DSurvey pilot app. Last time I experienced the hovering issue I ended up going back to DJI Go app to take some manual shots of the area I needed to survey, so yes, I would say that 100% of the time the drone flies with the DJI Go app but not with the 3DSurvey app, having the hovering problem.

* About compass calibration I usually do it when the DJI Go App asks for it, as I always enter this app first to calibrate camera and others, when I have had the need to calibrate I have done so, next time I encounter the hovering problem I will try to do it anyways in order to see if this helps with the issue, thanks for this tip.

* About firmware; I also updated the past week when the issue started to bother at work. I had the problem a couple of months ago, but as I stated in the original post, a reboot of the systems would fix the issue, then I had the problem at work so I updated the firmware of all devices and phone apps and phone itself in order to be with latest versions of firmware and software because I agree with you, sometimes this creates issues. Problem became recurrent. I suspect is not a problem of DJI or 3DSurvey App, or DD app but android, I will elaborate more in my last point of this post.

* About starting the mission from a flat surface, so far I always start the flights from a flat surface and clear area BUT in my last flight where I had bushes around (it was a complicated spot to survey), but after several tries, despite the bushes I managed to execute the mission,  not with the 3DSurvey app but with the DroneDeploy app (this is why I think it's something related to android because I also experienced the hovering with the DD app).

* About my idea that it may be android the problem, after posting here and messing a bit with my phone, not connected to the drone though, I was checking the flying apps and opened 3DSurvey Pilot app to look at the settings of my polygons, then closed the app and made sure the app was closed sliding the screen upwards and having the list of recently opened apps and sliding up from there (like here; https://youtu.be/kwxV48R0ad0?t=81), did the same with the DD app, but then I pressed the 3DSurvey icon on my phone and pressed on the info bubble above it. I found out the I had highlighted the option of force closing the app. So despite closing it as it is described in the video, the app seems to keep running in the background;



Could it be that this is creating the issue??? I haven't tested forcing the quit of the apps yet as I haven't been in the field since my last post, but it's something I will for sure try next time I need to fly (Next Monday).

* A question I have that may or may not be related to the issue: Do you think it is related to the platform I'm running the apps??? I've read in the past that several people comment that the DJI drones are made to be more compatible with mac products such as the iPad or iPhones, but coming from a linux background I totally prefer and use android. Would you, in your experience recommend me to invest in an iPad? Are you using the 3DSurvey app with android or iProducts?

Thanks again for your comments and sorry for the long post.

« Last Edit: September 17, 2021, 02:24:55 PM by ocar.campos »
Re: 3DSurvey Pilot - Drone hovering and not executing
« Reply #4 on: September 23, 2021, 08:34:02 PM »

So for the sake of the record and in case someone stumbles upon this thread having the same issue I report the following;

* I executed 5 missions this week, on the first one I had the hovering problem and after that one and after testing some theories I had, I managed to run the other 4 missions with no issues at all.

* My theory after this week is that there is an issue with Android and how the OS handles background running apps. I came to this conclusion after tuning the pipeline I was doing to execute my missions.

* For anyone stumbling upon this thread this is the tuned pipeline I followed this week that made me execute missions with no hovering problem. I'm using a P4P V 2.0 with a Moto G8 Power running android 11. All software and firmware is up to date.

The Pipeline

  • At the office; import the polygon into 3DSurvey App in the phone and configure the mission settings as needed. Save the mission for later execution. Repeat for as many polygons as needed. Ready to go to the field.
  • At the field; Phone goes into airplane mode to not receive calls or other things while executing the mission. Turn on drone, turn on drone's rc, wait for them to pair. Connect drone's rc to phone with the cable. Open DJI Go 4 App and configure preflight settings.
  • With DJI Go 4 App run a test flight to configure camera settings depending on local light and weather conditions, to make sure altitude of the planned mission is the right one, to make sure no obstacles are around and to make sure the drone is picking enough satellites and is able to fly and execute a mission. After configuring go back to home point. Land the drone. Shut it down. Shut down the rc. Close the DJI Go 4 App. Reboot the phone.
  • Once phone rebooted do not open any app. Phone still in airplane mode. Turn on drone. Turn on drone's rc. Wait for them to pair. Connect phone to drone's rc. Go straight to 3DSurvey app. Open your previously saved mission. Make sure the app shows the drone as connected. Press play to execute mission.
  • Wait for preflight checks to pass. Press play to execute mission.
  • Let the drone do its job.
  • After execution and landing, turn off drone, turn off drone's rc, exit app.

With the above pipeline I was able to fly 3 missions on a row with no problem at all. Compared to previous weeks this was total relief, the only downside is that I have to reboot my phone after running my initial configuring flight, but it allowed me to execute 3 missions on a row given that the weather conditions were stable enough to not go into DJI Go 4 App and reconfigure camera settings.

Hope this info helps someone in the future.

Re: 3DSurvey Pilot - Drone hovering and not executing
« Reply #5 on: October 01, 2021, 09:57:41 AM »
Thank you Oscar for this detailed pipeline Workflow!!!